filmov
tv
BGP Load Sharing When Dual Homed to One ISP
Показать описание
BGP Load Sharing When Dual Homed to One ISP
This scenario shows how to achieve load sharing when there are multiple connections to the same ISP through multiple local routers.
The two eBGP peers are terminated on two separate local routers. Load balancing on the two links is not possible because BGP chooses the single best path among the networks that is learned from eBGP and internal BGP (iBGP).
Load sharing among the multiple paths to AS 10 is the next-best option. With this type of load sharing, traffic to specific networks, on the basis of predefined policies, travels through both links.
Additionally, each link acts as a backup to the other link, in case one link fails.
**********
CONFIGURE:
**********
*****
R101:
*****
conf t
interface g0/1
ip address 192.168.11.1 255.255.255.0 secondary
ip address 192.168.12.1 255.255.255.0
!
interface g0/0
ip address 10.10.13.1 255.255.255.0
!
router bgp 11
no synchronization
bgp log-neighbor-changes
network 192.168.11.0
network 192.168.12.0
neighbor 10.10.13.3 remote-as 10
neighbor 10.10.13.3 route-map R101-103-MAP out
!--- The AS_PATH is increased for 192.168.12.0.
neighbor 192.168.12.2 remote-as 11
neighbor 192.168.12.2 next-hop-self
maximum-paths 2
no auto-summary
!
access-list 1 permit 192.168.12.0
access-list 2 permit 192.168.11.0
route-map R101-103-MAP permit 10
match ip address 1
set as-path prepend 11 11 11
!
route-map R101-103-MAP permit 20
match ip address 2
end
wr
*****
R102:
*****
conf t
interface g0/1
ip address 192.168.11.2 255.255.255.0 secondary
ip address 192.168.12.2 255.255.255.0
!
interface g0/0
ip address 10.10.24.2 255.255.255.0
!
router bgp 11
no synchronization
bgp log-neighbor-changes
network 192.168.11.0
network 192.168.12.0
neighbor 10.10.24.4 remote-as 10
neighbor 10.10.24.4 route-map R102-104-MAP out
!--- The AS_PATH is increased for 192.168.11.0.
neighbor 192.168.12.1 remote-as 11
neighbor 192.168.12.1 next-hop-self
no auto-summary
!
access-list 1 permit 192.168.11.0
access-list 2 permit 192.168.12.0
route-map R102-104-MAP permit 10
match ip address 1
set as-path prepend 11 11 11
!
route-map R102-104-MAP permit 20
match ip address 2
end
wr
*****
R103:
*****
conf t
interface g0/1
ip address 10.10.34.3 255.255.255.0
!
interface g0/0
ip address 10.10.13.3 255.255.255.0
!
router bgp 10
no synchronization
bgp log-neighbor-changes
network 10.10.34.0 mask 255.255.255.0
neighbor 10.10.13.1 remote-as 11
neighbor 10.10.13.1 default-originate
neighbor 10.10.34.4 remote-as 10
neighbor 10.10.34.4 next-hop-self
no auto-summary
!
*****
R104:
*****
conf t
interface g0/1
ip address 10.10.34.4 255.255.255.0
!
interface g0/0
ip address 10.10.24.4 255.255.255.0
!
router bgp 10
no synchronization
bgp log-neighbor-changes
network 10.10.34.0 mask 255.255.255.0
neighbor 10.10.24.2 remote-as 11
neighbor 10.10.24.2 default-originate
neighbor 10.10.34.3 remote-as 10
neighbor 10.10.34.3 next-hop-self
no auto-summary
end
wr
*******
VERIFY:
*******
show ip bgp
show ip route
🔔 Subscribe to my YouTube channel:
📺 Playlist of all my videos on BGP:
References:
#cisco #ccna #ccnp #ccie
This scenario shows how to achieve load sharing when there are multiple connections to the same ISP through multiple local routers.
The two eBGP peers are terminated on two separate local routers. Load balancing on the two links is not possible because BGP chooses the single best path among the networks that is learned from eBGP and internal BGP (iBGP).
Load sharing among the multiple paths to AS 10 is the next-best option. With this type of load sharing, traffic to specific networks, on the basis of predefined policies, travels through both links.
Additionally, each link acts as a backup to the other link, in case one link fails.
**********
CONFIGURE:
**********
*****
R101:
*****
conf t
interface g0/1
ip address 192.168.11.1 255.255.255.0 secondary
ip address 192.168.12.1 255.255.255.0
!
interface g0/0
ip address 10.10.13.1 255.255.255.0
!
router bgp 11
no synchronization
bgp log-neighbor-changes
network 192.168.11.0
network 192.168.12.0
neighbor 10.10.13.3 remote-as 10
neighbor 10.10.13.3 route-map R101-103-MAP out
!--- The AS_PATH is increased for 192.168.12.0.
neighbor 192.168.12.2 remote-as 11
neighbor 192.168.12.2 next-hop-self
maximum-paths 2
no auto-summary
!
access-list 1 permit 192.168.12.0
access-list 2 permit 192.168.11.0
route-map R101-103-MAP permit 10
match ip address 1
set as-path prepend 11 11 11
!
route-map R101-103-MAP permit 20
match ip address 2
end
wr
*****
R102:
*****
conf t
interface g0/1
ip address 192.168.11.2 255.255.255.0 secondary
ip address 192.168.12.2 255.255.255.0
!
interface g0/0
ip address 10.10.24.2 255.255.255.0
!
router bgp 11
no synchronization
bgp log-neighbor-changes
network 192.168.11.0
network 192.168.12.0
neighbor 10.10.24.4 remote-as 10
neighbor 10.10.24.4 route-map R102-104-MAP out
!--- The AS_PATH is increased for 192.168.11.0.
neighbor 192.168.12.1 remote-as 11
neighbor 192.168.12.1 next-hop-self
no auto-summary
!
access-list 1 permit 192.168.11.0
access-list 2 permit 192.168.12.0
route-map R102-104-MAP permit 10
match ip address 1
set as-path prepend 11 11 11
!
route-map R102-104-MAP permit 20
match ip address 2
end
wr
*****
R103:
*****
conf t
interface g0/1
ip address 10.10.34.3 255.255.255.0
!
interface g0/0
ip address 10.10.13.3 255.255.255.0
!
router bgp 10
no synchronization
bgp log-neighbor-changes
network 10.10.34.0 mask 255.255.255.0
neighbor 10.10.13.1 remote-as 11
neighbor 10.10.13.1 default-originate
neighbor 10.10.34.4 remote-as 10
neighbor 10.10.34.4 next-hop-self
no auto-summary
!
*****
R104:
*****
conf t
interface g0/1
ip address 10.10.34.4 255.255.255.0
!
interface g0/0
ip address 10.10.24.4 255.255.255.0
!
router bgp 10
no synchronization
bgp log-neighbor-changes
network 10.10.34.0 mask 255.255.255.0
neighbor 10.10.24.2 remote-as 11
neighbor 10.10.24.2 default-originate
neighbor 10.10.34.3 remote-as 10
neighbor 10.10.34.3 next-hop-self
no auto-summary
end
wr
*******
VERIFY:
*******
show ip bgp
show ip route
🔔 Subscribe to my YouTube channel:
📺 Playlist of all my videos on BGP:
References:
#cisco #ccna #ccnp #ccie
Комментарии