BGP Load Sharing: Multihomed to Two ISPs Through Multiple Local Routers

preview_player
Показать описание
BGP Load Sharing: Multihomed to Two ISPs Through Multiple Local Routers

BGP selects only the single best path to a destination among the BGP paths that are learned from different ASs, which makes load balancing impossible.
But, load sharing is possible in such multihomed BGP networks. On the basis of predetermined policies, traffic flow is controlled with different BGP attributes.

This section discusses the multihoming configuration that has the most frequent use. The configuration shows how to achieve load sharing.
See the Network Diagram, in which the multihome of AS 100 achieves reliability and load sharing.

CONFIGURE:
R1:
conf t
interface g0/0
ip address 192.168.31.1 255.255.255.0
!
interface g0/1
ip address 192.168.21.1 255.255.255.0
!
ip as-path access-list 1 permit ^300$
!
route-map AS-300-INCOMING permit 10
match as-path 1
set local-preference 200
!
!
access-list 10 permit 10.10.20.0 0.0.0.255
access-list 20 permit 10.10.10.0 0.0.0.255
!
route-map AS-300-OUTGOING permit 10
match ip address 10
set as-path prepend 100 100 100
!
route-map AS-300-OUTGOING permit 20
match ip address 20
!
router bgp 100
no synchronization
bgp log-neighbor-changes
network 10.10.10.0 mask 255.255.255.0
network 10.10.20.0 mask 255.255.255.0
neighbor 192.168.21.2 remote-as 100
neighbor 192.168.21.2 next-hop-self
neighbor 192.168.31.3 remote-as 300
neighbor 192.168.31.3 route-map AS-300-INCOMING in
neighbor 192.168.31.3 route-map AS-300-OUTGOING out
no auto-summary
end
wr
!
!
R2:
interface g0/1
ip address 192.168.21.2 255.255.255.0
!
interface g0/0
ip address 192.168.42.2 255.255.255.0
!
ip as-path access-list 1 permit ^400$
!
route-map AS-400-INCOMING permit 10
match as-path 1
set local-preference 150
!
!
access-list 10 permit 10.10.10.0 0.0.0.255
access-list 20 permit 10.10.20.0 0.0.0.255
!
route-map AS-400-OUTGOING permit 10
match ip address 10
set as-path prepend 100 100 100
!
route-map AS-400-OUTGOING permit 20
match ip address 20
!
router bgp 100
no synchronization
bgp log-neighbor-changes
network 10.10.10.0 mask 255.255.255.0
network 10.10.20.0 mask 255.255.255.0
neighbor 192.168.21.1 remote-as 100
neighbor 192.168.21.1 next-hop-self
neighbor 192.168.42.4 remote-as 400
neighbor 192.168.42.4 route-map AS-400-INCOMING in
neighbor 192.168.42.4 route-map AS-400-OUTGOING out
no auto-summary
end
wr

VERIFY:
show ip bgp
show ip route

🔔 Subscribe to my YouTube channel:

📺 Playlist of all my videos on BGP:

References:

#cisco #ccna #ccnp #ccie
Рекомендации по теме