filmov
tv
How to Configure VRF Lite on Cisco IOS
Показать описание
How to Configure VRF Lite on Cisco IOS
Table of Contents:
VRF stands for virtual routing and forwarding, or sometimes we see that it's called VPN routing and forwarding.
This is a technology that allows us to create multiple routing tables/instances within a router.
VRF Lite means VRFs without any MPLS config. VRFs do not always mean MPLS. And MPLS does not always mean VRFs.
Configuring VRF Lite
1. Router(config)# ip vrf vrf-name
2. Router(config)# interface type number
3. Router(config-vrf)# ip vrf forwarding vrf-name
4. Router(config-if)# end
5. Router# copy running-config startup-config
Configuration:
ISP:
conf t
ip vrf BLUE
ip vrf RED
!
interface GigabitEthernet0/0
ip vrf forwarding BLUE
ip address 10.10.1.254 255.255.255.0
!
interface GigabitEthernet0/1
ip vrf forwarding RED
ip address 10.10.3.254 255.255.255.0
!
Configuring static routes in VRFs:
ip route vrf BLUE 1.1.1.1 255.255.255.255 10.10.1.1
ip route vrf RED 3.3.3.3 255.255.255.255 10.10.3.1
!
Verification:
ISP:
show ip vrf
ping vrf BLUE 1.1.1.1
ping vrf RED 3.3.3.3
show ip route vrf RED
show ip route vrf BLUE
show ip route
no ip route vrf BLUE 1.1.1.1 255.255.255.255 10.10.1.1
no ip route vrf RED 3.3.3.3 255.255.255.255 10.10.3.1
Configuring routing protocols in VRFs:
BLUE:
router ospf 1
network 10.10.1.0 0.0.0.255 area 0
network 1.1.1.1 0.0.0.0 area 0
!
RED:
router ospf 1
network 3.3.3.3 0.0.0.0 area 0
network 10.10.3.0 0.0.0.255 area 0
ISP:
router ospf 1 vrf BLUE
network 10.10.1.0 0.0.0.255 area 0
!
router ospf 2 vrf RED
network 10.10.3.0 0.0.0.255 area 0
!
Verification:
ISP:
show ip vrf
show ip route vrf BLUE ospf
show ip route vrf RED ospf
ping vrf BLUE 1.1.1.1
ping vrf RED 3.3.3.3
show ip route
Monitoring and Verifying VRF Lite
NOTE: Normal commands become "VRF Aware".
Command Purpose
Router# show ip vrf Displays the set of VRFs and interfaces.
Router# show ip route vrf vrf-name Displays the IP routing table for a VRF.
Router# show ip protocols vrf vrf-name Displays the routing protocol information for a VRF.
Router# ping vrf vrf-name ip ip-address Pings an ip address that has a specific VRF.
Router# show run vrf
Router# traceroute vrf vrf-name
#CISCO #CCNP #CCIE
References:
#cisco #ccna #ccnp #ccie
Table of Contents:
VRF stands for virtual routing and forwarding, or sometimes we see that it's called VPN routing and forwarding.
This is a technology that allows us to create multiple routing tables/instances within a router.
VRF Lite means VRFs without any MPLS config. VRFs do not always mean MPLS. And MPLS does not always mean VRFs.
Configuring VRF Lite
1. Router(config)# ip vrf vrf-name
2. Router(config)# interface type number
3. Router(config-vrf)# ip vrf forwarding vrf-name
4. Router(config-if)# end
5. Router# copy running-config startup-config
Configuration:
ISP:
conf t
ip vrf BLUE
ip vrf RED
!
interface GigabitEthernet0/0
ip vrf forwarding BLUE
ip address 10.10.1.254 255.255.255.0
!
interface GigabitEthernet0/1
ip vrf forwarding RED
ip address 10.10.3.254 255.255.255.0
!
Configuring static routes in VRFs:
ip route vrf BLUE 1.1.1.1 255.255.255.255 10.10.1.1
ip route vrf RED 3.3.3.3 255.255.255.255 10.10.3.1
!
Verification:
ISP:
show ip vrf
ping vrf BLUE 1.1.1.1
ping vrf RED 3.3.3.3
show ip route vrf RED
show ip route vrf BLUE
show ip route
no ip route vrf BLUE 1.1.1.1 255.255.255.255 10.10.1.1
no ip route vrf RED 3.3.3.3 255.255.255.255 10.10.3.1
Configuring routing protocols in VRFs:
BLUE:
router ospf 1
network 10.10.1.0 0.0.0.255 area 0
network 1.1.1.1 0.0.0.0 area 0
!
RED:
router ospf 1
network 3.3.3.3 0.0.0.0 area 0
network 10.10.3.0 0.0.0.255 area 0
ISP:
router ospf 1 vrf BLUE
network 10.10.1.0 0.0.0.255 area 0
!
router ospf 2 vrf RED
network 10.10.3.0 0.0.0.255 area 0
!
Verification:
ISP:
show ip vrf
show ip route vrf BLUE ospf
show ip route vrf RED ospf
ping vrf BLUE 1.1.1.1
ping vrf RED 3.3.3.3
show ip route
Monitoring and Verifying VRF Lite
NOTE: Normal commands become "VRF Aware".
Command Purpose
Router# show ip vrf Displays the set of VRFs and interfaces.
Router# show ip route vrf vrf-name Displays the IP routing table for a VRF.
Router# show ip protocols vrf vrf-name Displays the routing protocol information for a VRF.
Router# ping vrf vrf-name ip ip-address Pings an ip address that has a specific VRF.
Router# show run vrf
Router# traceroute vrf vrf-name
#CISCO #CCNP #CCIE
References:
#cisco #ccna #ccnp #ccie
Комментарии