How to Leak Routes Between Different VRFs

preview_player
Показать описание
TIMESTAMPS:
0:00 Introduction
0:55 Talking about the topology
3:16 Configuring and verifying route leaking
10:56 Verification commands and performing pings

How to Leak Routes Between Different VRFs:
CONFIGURE:
PE-4:
ip vrf VPN1
!
interface GigabitEthernet0/0
ip vrf forwarding VPN1
ip address 10.1.2.5 255.255.255.252
exit
ip vrf VPN1
rd 100:1
route-target export 100:1
route-target import 200:1
!
ip vrf VPN2
!
interface GigabitEthernet0/1
ip vrf forwarding VPN2
ip address 10.0.2.1 255.255.255.0
exit
ip vrf VPN2
rd 200:1
route-target export 200:1
route-target import 100:1
!
ip route vrf VPN2 3.3.3 .3 255.255.255.255 10.0.2.2
ip route vrf VPN1 1.1.1.1 255.255.255.255 10.1.2.6
!
router bgp 1
bgp router-id 4.4.4.4
bgp log-neighbor-changes
!
address-family ipv4 vrf VPN1
redistribute connected
redistribute static
exit-address-family
!
address-family ipv4 vrf VPN2
redistribute connected
redistribute static
exit-address-family
!
!
end
wr

CE-3:
conf t
ip route 0.0.0.0 0.0.0.0 10.1.2.5
end
wr
!
CE-4:
conf t
ip route 0.0.0.0 0.0.0.0 10.0.2.1
end
wr

VERIFY:
show ip route vrf VPN1
show ip route vrf VPN2
show ip bgp vpnv4 all
show bgp vpnv4 unicast vrf VPN1
show bgp vpnv4 unicast vrf VPN2
From CE-3, ping 3.3.3.3 source 1.1.1.1
From CE-4, ping 1.1.1.1 source 3.3.3.3

Router# show ip vrf Displays the set of VRFs and interfaces.
Router# show ip route vrf vrf-name Displays the IP routing table for a VRF.
Router# show ip protocols vrf vrf-name Displays the routing protocol information for a VRF.
Router# ping vrf vrf-name ip ip-address Pings an ip address that has a specific VRF.
Router# show run vrf
Router# traceroute vrf vrf-name

#cisco #ccna #ccnp #ccie
Рекомендации по теме
Комментарии
Автор

TIMESTAMPS:
0:00 Introduction
0:55 Talking about the topology
3:16 Configuring and verifying route leaking
10:56 Verification commands and performing pings

I hope you found this video helpful, please like, subscribe and click the notification bell so you won't miss future videos. Thanks for your support! ❤

FerdsTechChannel