Python and Linux on Cisco IOS?

preview_player
Показать описание
Run Python and Linux directly on IOS XE? Yes you can! Take your network automation skills to the next level with scripting and automation directly on Cisco devices. You can be a DevNet Engineer!

Amaze others with your knowledge of the Cisco IOS. You don't need python for these scripts. Rock that job interview and show senior network engineers what you can do. Keep on learning and change your life. Get that good paying job by showing your skills.

Menu:
Overview: 0:00
Lab Setup (GNS3 / CSR): 2:00
IOS XE & Container explanation: 3:14
Guestshell Setup: 7:14
Access the Linux Shell: 13:48
Sort out routing: 15:11
SSH to Guestshell remotely: 19:30
Install applications: 22:20
Python scripting: 23:14

=================================
David's Linux & Cisco playlist:
=================================

=================================
Documentation:
=================================

================================
Books:
=================================

=================================
Free DevNet Labs:
=================================

=================================
CSR Configuration steps:
=================================
! Check if service is running
en
show iox-service

! Configure Basics
conf t
hostname CSR1
interface GigabitEthernet1
no shut
ip address 10.1.1.1 255.255.255.0
exit
exit

! Enable the service
conf t
iox
exit
show iox-service

! Configure Virtual Port
conf t
interface VirtualPortGroup0
ip unnumbered GigabitEthernet1
exit
exit

! Enable the guestshell
guestshell enable VirtualPortGroup 0 guest-ip 10.1.1.2

! Access guestshell
guestshell run bash

! Add DNS information to Linux container

! Need to set up routing so Router knows how to route
conf t
ip route 10.1.1.2 255.255.255.255 virtualportgroup 0
ip route 0.0.0.0 0.0.0.0 10.1.1.254
ip domain-lookup
ip name-server 8.8.8.8
exit

! Check stuff on guestshell host
======================
sudo ifconfig

!Add a user
sudo useradd david
sudo passwd david

! Install nano and Python 3
sudo yum install nano -y

! You don't need Python3 for these script examples
sudo yum install python3

=================================
Python Script:
=================================
import sys
import cli

=================================
Documentation
=================================

DevNet
10x Engineer
CCNA
Cisco Devnet Associate
Python
Devnet cert

CCNP Enterprise
CCNP Security
CCNP Data Center
CCNP Service Provider
CCNP Collaboration
Cisco Certified Devnet Professional
Cisco Certified Network Professional

LPIC 1
LPIC 2
Linux Professional Institute
LX0-103
LX0-104
XK0-004

#python #linux #DevNet
Рекомендации по теме
Комментарии
Автор

Menu:
Overview: 0:00
Lab Setup (GNS3 / CSR): 2:00
IOS XE & Container explanation: 3:14
Guestshell Setup: 7:14
Access the Linux Shell: 13:48
Sort out routing: 15:11
SSH to Guestshell remotely: 19:30
Install applications: 22:20
Python scripting: 23:14


David's Linux & Cisco playlist:




Documentation:


Books:




Free DevNet Labs:



CSR Configuration steps:

! Check if service is running
en
show iox-service

! Configure Basics
conf t
hostname CSR1
interface GigabitEthernet1
no shut
ip address 10.1.1.1 255.255.255.0
exit
exit

! Enable the service
conf t
iox
exit
show iox-service

! Configure Virtual Port
conf t
interface VirtualPortGroup0
ip unnumbered GigabitEthernet1
exit
exit

! Enable the guestshell
guestshell enable VirtualPortGroup 0 guest-ip 10.1.1.2

! Access guestshell
guestshell run bash

! Add DNS information to Linux container
echo nameserver 8.8.8.8 | sudo tee —append /etc/resolv.conf

! Need to set up routing so Router knows how to route
conf t
ip route 10.1.1.2 255.255.255.255 virtualportgroup 0
ip route 0.0.0.0 0.0.0.0 10.1.1.254
ip domain-lookup
ip name-server 8.8.8.8
exit
! Check stuff on guestshell host
sudo ifconfig
cat /etc/resolv.conf
!Add a user
sudo useradd david
sudo passwd david
! Install nano and Python 3
sudo yum install nano -y
! You don't need Python3 for these script examples
sudo yum install python3

Python Script:

import sys
import cli
cli.executep(‘show ip int brief’)
cli.executep(‘show ver’)

Documentation



davidbombal
Автор

David: I really enjoy your videos. They of necessity require in-depth discussion in order to understand the subject matter. The length is just right. Don't change a thing. Your collection of videos has a great span of complexity going from beginner through to expert level coverage. The key I find to your video's it that you provide enough detail for me (at least) to be able to duplicate your setup in GNS3 which then gives me a starting point from which I can continue to test and experiment. That in itself is a HUGE benefit. Keep it up!!! Many thanks.
Glenn

stampeder
Автор

Pls dont stop making these vids. I learn so much off your content. Your content is great. And yes, sometimes i have to watchbit a few times to grasp the concepts 💡. However, that is not boredom, its passion and wanting to add these skills to my bag and advance in i.t. rather than remain level. i like that the lessons are in 1 long video.

shiloh
Автор

Big fan of your content! Personally prefer the in depth stuff that you do like this video. I always find with programming and networking tutorials that the longer the better. A really in depth video that’s a hour or two long will teach so much more complex stuff than the surface level topics shorter videos cover. Thanks for everything you do!!

linux_with_anakin
Автор

Hi @David Bombal!!! Thank you for all of your free content on Automation and Network Programability and for supporting the way to create the new Hybrid Networking Engineer!!! As you say... The next 10x Engineer!!! Best regards, and I hope to see you and meet you this year in Cisco Live Las Vegas!!!

jesusespinoza-online
Автор

Everyone remembers what you said about time management & cutting out noise last year, and these videos are an additional help. The year to reach goals is this one, not next year. The longer videos the better!

catharsis
Автор

Your videos are all full of very useful content. I do not mind any length. Many thanks.

genc_emekli
Автор

Yes please provide us more video about automation on Cisco and Python

malkta
Автор

David absolutely I love your work, you have separated yourself from the rest. Thank you for helping me on my Cisco certification

jesussaeta
Автор

Your video's on this series (past three and this one) are absolutely awesome. I was in a rut after passing my CCNA quickly (mind you with flying colors i.e. 900+ score due from your Udemy courses) but I failed my CCNP 300-101 test. I love Cisco, Networking, Python, Linux, etc but the fail threw me for a loop putting a huge doubt in my mind. I was studying feverishly to pass the 300-101 but always pushing the test off two days before it was due in PearsonVue as the fail was a blow. I watch your videos regularly but the past few with Linux totally rekindled my curiosity. They gave me that boost I needed. I found myself writing scripts and playing further discovering I knew a lot more then I thought I did. I didn't push my retake test off this week in PearsonVue for the 300-101 and I finally passed 850+. You do awesome stuff for the Cisco/Networking community and I thought you should know you pushed someone across the pond to do better. Thank you.

jonathanmblair
Автор

Definitely one of my favorites videos from you David ! It really opens up a new World of possibilities

yurisalarich
Автор

No matter it's 30-50 min video, Love to learn in dept from you Sir David, would like to see the post's

tennysondesouza
Автор

David I've been following you and networkchuck for a while and I've come to notice that you both give a lot in a different and unique way, I tend to be motivated by your videos and thrilled that I have a quality and in depth lessons waiting for me in your videos specially in yours, I wouldn't change a thing I would really like to help you deliver better content but I just don't know how to make it better so I can just say thank you for what you give already I like your videos but many times life catches up or I get distracted because I'm tired or something I've transitioned from a networking role to a developer role just by opening my mind listening to you guys even though my steps are slow I believe I've come a long way because hey I was just your classical Cisco fan boy, listening to you guys and dipping my toes on the deep pool that is IT as a whole I feel I've become a better professional for that I'll be forever grateful and I'll keep listening to both of you! Congratulations for making rich quality content keep it up!

kharos
Автор

David... I just want to be just like you mate!

marvinreyes
Автор

Thanks again for another great video. When they are under 30 minutes I can watch during my lunch break!

jeffreyglennon
Автор

Great vid, the 30 min vids are perfect, you are an amazing teacher. Thank you for all you do, we appreciate it.

danielacosta
Автор

You always surprise us, learnt something new.
Not too long, and yes we would like those in-depth because they are well curated by you👌🏼
Also, I thank you very much for the ICND1 and 2 course with Wireshark Ethical.. Course, which actually gave away. I find them a lot useful. So thanks Mr. David♥️🔥

techymoh
Автор

Thanks a lot David for this (certainly not too long video) and helpful insights. You explanation and examples are really helpful and understandable, even for me :-)

ÐÞæ
Автор

estoy aprendiendo python y desde hace tiempo que vengo estudiando redes cisco me enganchaste con eso subscrito y campanita saludos desde Vzla profe!

panchaleon
Автор

David, this type of videos are just great! Please keep creating content like this!!!

Cleonexx